Brightspace Slowness and Outages

Incident Report for Wentworth Institute of Technology

Postmortem

An Amazon Web Services (AWS) outage on October 20, 2025, caused intermittent issues with the D2L Brightspace learning management system. The AWS disruption affected the US-EAST-1 region, where many websites and services, including D2L, are hosted. Once the AWS outage was resolved, D2L Brightspace returned to normal functionality.

Posted Oct 24, 2025 - 10:14 EDT

Resolved

The AWS outage has been resolved and Brightspace and the tools integrated with it are running as expected.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Oct 21, 2025 - 08:44 EDT

Identified

Brightspace has reported the following: "Due to the ongoing AWS outage D2L (Brightspace) is unable to scale to support increased usage. Users may experience slowness and outages until the AWS outage is resolved."

Once we have more information we will provide updates here.
Posted Oct 20, 2025 - 08:39 EDT
This incident affected: D2L Brightspace.