Update on Registration Override Process
Incident Report for Wentworth Institute of Technology
Resolved
After reviewing reported issues with today's registration, we have removed the newly implemented “automatic override” process. This process was intended to streamline the steps required when students exceed 20 credits per semester or repeat a course.

If you need assistance requesting an override to repeat a course or register for courses exceeding 20 credits, please contact the Registrar’s Office at registrar@wit.edu.
Posted Mar 16, 2021 - 15:00 EDT