Poppulo Email Publishing Display Error

Incident Report for Wentworth Institute of Technology

Postmortem

Refer to Poppulo’s incident notes: https://poppulo1.statuspage.io/incidents/mdt8z92hgxhd

Posted Nov 25, 2025 - 12:46 EST

Resolved

Poppulo's US Service Team has fully resolved the issue at this time.

If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Nov 25, 2025 - 12:46 EST

Identified

Poppulo's US Service Team has identified a performance error with email sending:

"While a publishing error may display, mails are sending and delivering to recipients. Our Incident Response teams have been engaged and are looking into the issue."
Posted Nov 25, 2025 - 12:41 EST
This incident affected: Other Services.