Links in emails not working properly.
Incident Report for Wentworth Institute of Technology
Resolved
This incident has been resolved.
Posted 4 months ago. Jan 29, 2019 - 22:17 EST
Monitoring
At this time service may be available. Microsoft is continuing to work on the issue and we will confirm once it has been fully tested.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 4 months ago. Jan 29, 2019 - 12:24 EST
Identified
The Microsoft Safelinks system which scans links in email for potential harmful content is experiencing interruptions. This may lead to errors when attempting to access those links in email. This is impacting all Microsoft customers.

Microsoft is working to resolve the issue. We will provide updates once they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 4 months ago. Jan 29, 2019 - 11:34 EST
This incident affected: Cloud Productivity Tools.