Phone System Issues
Incident Report for Wentworth Institute of Technology
Resolved
The issue with the phone system has been resolved.
If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 7 months ago. Dec 19, 2018 - 13:29 EST
Identified
We have identified the issue with the phone system and are working on a resolution. This is currently impacting the phone numbers for Admissions, Wellness, and the main Wentworth number. Other phone numbers should not be impacted.
Posted 7 months ago. Dec 19, 2018 - 11:58 EST
Update
We are continuing to investigate this issue.
Posted 7 months ago. Dec 19, 2018 - 11:56 EST
Investigating
DTS is currently investigating an issue where some Wentworth numbers are not able to receive external calls. We will provide an update as soon as possible.
Posted 7 months ago. Dec 19, 2018 - 11:31 EST
This incident affected: Telephony & Collaboration.