Email - Microsoft Outlook Email not responding or responding slowly
Incident Report for Wentworth Institute of Technology
Postmortem

This isssue was caused by an update that Microsoft made to their Microsoft 365 infrastructure. They identified the problematic update and reverted it. They also work to prevent the update from propagating further across their service. The issue reoccurred several times, each time with diminishing impact.

Posted Jun 07, 2023 - 08:41 EDT

Resolved
This issue has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Jun 05, 2023 - 14:50 EDT
Monitoring
At this time service may be available. We are continuing to monitor the service and we will confirm once it has been fully tested.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Jun 05, 2023 - 13:15 EDT
Update
Microsoft has identified an update which was applied around the time that the impact started. They have prevented the potentially problematic update from propagating further across the service and are reviewing options to revert the change quickly and safely in those portions of the Microsoft infrastructure where it has been applied.
Posted Jun 05, 2023 - 12:23 EDT
Identified
Microsoft has acknowledged an issue with their Outlook cloud services. As soon as we get any further update from them we will publish it here.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Jun 05, 2023 - 11:13 EDT
Investigating
DTS is investigating an issue with Microsoft Outlook email not responding or responding slowly.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Jun 05, 2023 - 11:00 EDT
This incident affected: Cloud Productivity Tools.