LeopardWeb and Banner Admin Unavailable
Incident Report for Wentworth Institute of Technology
Resolved
This incident has been resolved.
Posted Apr 22, 2021 - 17:35 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 22, 2021 - 16:15 EDT
Investigating
We are investigating issues logging into LeopardWeb and Banner Admin and hope to have this resolved soon.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Apr 22, 2021 - 15:56 EDT
This incident affected: Student Information System.