Duo Two-Factor via Phone Call not working
Incident Report for Wentworth Institute of Technology
Resolved
Duo confirmed this incident as resolved. Please note the change where authentication calls will come from +1-669-201-9315 when they previously displayed the Tech Spot phone number.

We're awaiting an after incident report from Duo to understand if this is a temporary or permanent change.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Nov 07, 2019 - 22:55 EST
Monitoring
Duo has indicated that the problem has been resolved. We are continuing to monitor the service and we will confirm once it has been fully tested.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Nov 07, 2019 - 16:17 EST
Identified
Duo provided the following update:

We have made a change to the default number from which phone call authentications are sent.

The new caller ID that users will see is +1-669-201-9315.
Posted Nov 07, 2019 - 16:16 EST
Update
Duo has indicated the problem is ongoing at this time and that they are continuing to investigate.

Updates will be posted as they become available.
Posted Nov 07, 2019 - 15:33 EST
Investigating
Duo has reported that users who authenticate via voice phone call are not receiving calls at this time. They are aware and working to resolve the problem.

We encourage our users to utilize the Duo App for the best experience. If you are having trouble accessing your account, please contact the Tech Spot and request a Bypass Code for today.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Nov 07, 2019 - 12:50 EST
This incident affected: Authentication & Single Sign On (Authentication & Single Sign On).