Intermittent network interruptions in 610 Huntington
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Jul 25, 2020 - 12:56 EDT
Investigating
We are investigating intermittent network interruptions in 610 Huntington. Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Jul 25, 2020 - 08:15 EDT
This incident affected: Internet and Network Access.