Tech Spot Phone Issue

Incident Report for Wentworth Institute of Technology

Postmortem

Intermittent issues calling the Tech Spot phone number were reported. After investigating, it was found that one particular help desk agent phone was not working properly. That agent phone was taken out of service and normal call activity resumed.

Posted Jun 13, 2025 - 09:17 EDT

Resolved

This issue has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Jun 02, 2025 - 12:05 EDT

Monitoring

We believe the Tech Spot phone issue is resolved. DTS is continuing to monitor the service and we will confirm once it has been fully tested.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at techspot@wit.edu.
Posted Jun 02, 2025 - 10:14 EDT

Investigating

DTS has identified a service interruption for Tech Spot Phones, 617-989-4500. At this time if you have a issue please email us at techspot@wit.edu.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Jun 02, 2025 - 09:17 EDT
This incident affected: Telephony & Collaboration (Telephony & Collaboration).