CoVerified app not available for download in Google Play
Incident Report for Wentworth Institute of Technology
Resolved
A workaround has been implemented. To download on Android devices please visit https://www.coverified.us/download and follow the instructions.
Posted Nov 15, 2021 - 12:20 EST
Identified
The vendor has informed us that Google pulled applications involving COVID-19 vaccinations without warning. They are working to be re-certified and restore the app to the store.

In the interim, we have updated the CoVerified tile in myWentworth to open the web version on Android devices. Those who already have the app installed should avoid uninstalling it as they will not be able to re-download.
Posted Oct 18, 2021 - 12:45 EDT
Investigating
We are investigating reports that the CoVerified app is not available for download in Google Play. Users who already have the app downloaded should not be affected. The web version can be accessed at https://campus.coverified.us as a workaround.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Oct 14, 2021 - 14:28 EDT
This incident affected: Other Services.