Resolved - EAB Navigate Degradation of Service

Incident Report for Wentworth Institute of Technology

Postmortem

EAB sent a notice via their statuspage at 9:17 a.m. on 8/25 to alert us that the Navigate platform was experiencing degradation of service. At 11:02, the follow-up notification let us know that the issue was resolved and the service was fully available again. EAB did not provide a postmortem with more details about this incident.

Posted Sep 04, 2025 - 14:46 EDT

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 12:48 EDT

Investigating

Engineers at EAB have acknowledged a service interruption for Navigate for student advising.

They are currently working to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Aug 25, 2025 - 09:54 EDT
This incident affected: Other Services.