LeopardGuest - Guest Wireless Network Interruption
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Aug 26, 2020 - 14:40 EDT
Update
We are continuing to work with our network vendor to resolve the underlying issue.
Posted Aug 24, 2020 - 09:26 EDT
Identified
Engineers have acknowledged a service interruption for LeopardGuest the guest wireless system. When using this system the registration page is not showing in Chrome or Edge. It is showing in Firefox and Internet Explorer. Users needing to use this ystem should switch browsers after connecting and should see the registration page allowing access to the service.

We are currently working to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Aug 19, 2020 - 14:21 EDT
This incident affected: Internet and Network Access.