Brightspace System Slowness
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Dec 01, 2020 - 10:46 EST
Investigating
D2L has notified us that starting at 10 PM, Nov. 30th our system began loading slowly. They are working to fully restore service at this time.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Dec 01, 2020 - 09:54 EST
This incident affected: Digital Learning Environment (D2L Brightspace).