Wentworth 214 AV out of order
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Oct 08, 2021 - 16:37 EDT
Update
While repairing the initial cause of this outage an additional issue was discovered requiring parts that are on backorder. A temporary projector cart remains in the space for use.
Posted Oct 06, 2021 - 09:12 EDT
Identified
The projector and media equipment in Wentworth 214 are currently out of order. We have placed a projector cart into this space for your use.

We are currently working to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Sep 05, 2021 - 10:15 EDT
This incident affected: Classroom & Conference Room Audio/Video Systems.