555 Huntington Follow Me Printer Unavailable
Incident Report for Wentworth Institute of Technology
Resolved
The 555 Huntington Follow Me Printer is now available.
Posted 7 days ago. Jan 09, 2019 - 14:41 EST
Identified
We are aware of a hardware issue with the Follow Me Printer located in 555 Huntington Avenue. Students should pick up their print jobs from alternate locations listed below until further notice.

* Douglas D. Schumann Library & Learning Commons
* Flanagan Campus Center
* Architecture Studios
* Interior Design Studio
* Industrial Design Studio
Posted 8 days ago. Jan 09, 2019 - 12:31 EST
This incident affected: Printing, Plotting, & Scanning.