Partial Network Interruption due to Main Campus Power Outage

Incident Report for Wentworth Institute of Technology

Postmortem

There was an incident related to construction at 7:45 AM that caused a power outage in multiple buildings. Network access was unavailable in buildings with no power. Power was restored to most buildings by 10:00 AM. Beatty Hall power was restored at 3:30 PM. All systems are operational at this time.

Posted Jul 07, 2026 - 09:38 EDT

Resolved

This issue has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Jul 07, 2026 - 09:33 EDT

Monitoring

At this time, all network services appear to be available. We will continue to monitor systems and will provide updates if any additional impacts related to the earlier power outage are identified.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Jul 06, 2026 - 19:56 EDT

Identified

Due to the power outage that is impacting the main campus buildings some network services will be unavailable.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at techspot@wit.edu.
Posted Jul 06, 2026 - 09:01 EDT
This incident affected: Internet and Network Access.