Inbound and Outbound Phone Calls Not Completing
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been resolved.
Posted 2 months ago. Oct 01, 2018 - 14:11 EDT
Investigating
We are investigating an issue with not being able to place or receive calls from outside the campus. Internal calls are not impacted.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 2 months ago. Oct 01, 2018 - 08:57 EDT