PC Software Distribution Unavailable
Incident Report for Wentworth Institute of Technology
Resolved
Software Distribution for PCs has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted May 28, 2020 - 18:09 EDT
Identified
Engineers have acknowledged a service interruption for PC Software Distribution.

We are currently working to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted May 28, 2020 - 15:41 EDT
This incident affected: Software Download & Licensing.