Phone Service Interruption on Campus
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Aug 19, 2020 - 16:08 EDT
Monitoring
At this time service phone service is available again. Engineers are continuing to monitor the service and we will confirm once it has been fully tested.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Aug 19, 2020 - 14:42 EDT
Update
We are continuing to investigate this issue.
Posted Aug 19, 2020 - 14:41 EDT
Investigating
DTS is investigating an issue with phone service on campus. Incoming and Outgoing calls are not working.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Aug 19, 2020 - 14:34 EDT
This incident affected: Telephony & Collaboration (Telephony & Collaboration).