VPN Connection Timeout

Incident Report for Wentworth Institute of Technology

Resolved

At this time normal connectivity between Verizon users and Wentworth services (including VPN) should be available. Engineers are continuing to monitor the service and consider this issue resolved, if we receive additional information from the vendor we will update.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at techspot@wit.edu.
Posted Jul 11, 2025 - 15:13 EDT

Identified

Engineers have confirmed this issue with Verizon. We continue along with other COF engineers to troubleshoot this issue and have engaged our Internet Service Providers (ISPs) and support vendor. You may also experience other connectivity issues reaching Wentworth sites (non VPN) if on Verizon. As this is an external issue as we receive updates from the vendor we will update.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at techspot@wit.edu or 617.989.4500.
Posted Jul 11, 2025 - 13:03 EDT

Update

The issue appears to be isolated to Verizon home internet users. Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Jul 11, 2025 - 09:42 EDT

Investigating

We are currently investigating reports of VPN connection issues. More information will be posted as soon as available.
Posted Jul 11, 2025 - 09:15 EDT
This incident affected: Internet and Network Access.