Beatty 302 AV outage
Incident Report for Wentworth Institute of Technology
Resolved
The AV system in Beatty 302 has been repaired. The equipment is now operational.
Posted Feb 04, 2021 - 15:34 EST
Investigating
The AV system in Beatty 302 is currently out of order. We are investigating the issue.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Feb 04, 2021 - 14:20 EST
This incident affected: Classroom & Conference Room Audio/Video Systems.