Service interruptions for Office 365 & Duo
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Mar 16, 2021 - 07:46 EDT
Update
Microsoft reports many services have been restored, but work is ongoing for a small sub-set of users. It is not known if this includes people or services used by Wentworth. Next from us expected at open of business Tuesday, 3/16/21.
Posted Mar 15, 2021 - 23:12 EDT
Investigating
We are currently monitoring service interruptions for Office 365 & Duo. These outages appear to be related and affect users who are being prompted to re-login to various services and may appear at any time.

Additional details from Microsoft: https://status.office.com/
Additional details from Duo: https://status.duo.com/incidents/mg17fsdbb67p

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Mar 15, 2021 - 16:58 EDT
This incident affected: Authentication & Single Sign On (Authentication & Single Sign On) and Cloud Productivity Tools.