Microsoft Windows Activation Warning
Incident Report for Wentworth Institute of Technology
Resolved
Those computers that were waiting for windows activation are able to activate at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Sep 11, 2021 - 12:52 EDT
Update
A fix for this problem is being implemented and should resolve itself in 24 - 48 hours. An update will be posted when we get notice from Microsoft.
Posted Sep 10, 2021 - 12:05 EDT
Identified
Some students may experience a warning message about Windows not activating. We are currently working to resolve this and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Sep 10, 2021 - 11:20 EDT
This incident affected: Software Download & Licensing.