Navigate360 Student Success - some data missing

Incident Report for Wentworth Institute of Technology

Postmortem

EAB identified an issue with the data feeds for many schools on the morning of 12/1/25. Once they identified the root cause, they addressed and the feeds resumed by noon. EAB did not provide further details of what caused the disruption.

Posted Dec 08, 2025 - 10:07 EST

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 10:22 EST

Monitoring

We are aware that blocks of data are missing from the Navigate360 Student Success platform. This is an issue impacting other schools as well, and EAB is working on a resolution.

We are monitoring the situation and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Dec 01, 2025 - 10:00 EST
This incident affected: Other Services.