Printing Services Unavailable
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu. Thank you for your patience while we worked to restore normal service.
Posted about 1 month ago. Dec 11, 2018 - 15:45 EST
Update
Users may be able to send new print jobs to a printer or release a job from the Follow Me Printing service.
Posted about 1 month ago. Dec 11, 2018 - 15:44 EST
Investigating
We are currently investigating an issue with printing.
Posted about 1 month ago. Dec 11, 2018 - 15:12 EST
This incident affected: Printing, Plotting, & Scanning.