DesignJet Plotter Service Interruption

Incident Report for Wentworth Institute of Technology

Resolved

The issue affecting the Library DesignJet plotter has been fully resolved, and the device is back in service.

To support a smooth return to normal operations, Tech Spot staff will be available in the Library this weekend to assist with printing and plotting. Staff will also be conducting walkthroughs in Annex South and Annex East to provide support as needed.

Thank you for your patience while we worked with the vendor to resolve this issue. If you experience any printing or plotting issues, please contact the Tech Spot at techspot@wit.edu.
Posted Jul 31, 2026 - 14:30 EDT

Identified

The DesignJet plotter located in the Library is currently out of service.

We have contacted the vendor and are actively working with them to restore service as quickly as possible. Updates will be posted as they become available.

In the meantime:
- The DesignJet plotters in Annex South and Annex East remain operational and available for use.
- School of Architecture and Design (SoAD) students should use the Annex South or Annex East DesignJet plotters
- We recommend to all other use the PageWides printer for their printing needs.

If you have questions or need assistance with printing options, please contact the Tech Spot at techspot@wit.edu.
Posted Jul 30, 2026 - 14:27 EDT
This incident affected: Printing, Plotting, & Scanning.