Flanagan Campus Center Follow Me Printer unavailable
Incident Report for Wentworth Institute of Technology
Resolved
This incident has been resolved.
Posted Jan 17, 2020 - 11:14 EST
Identified
We are aware that the Flanagan Campus Center Follow Me Printer, located outside of the Schumann Fitness Center on the ground floor, is currently unavailable. A technician has reviewed the machine and we are awaiting parts to repair it.

You can pickup your print jobs at any of the other Follow Me locations, including four within the Douglas D. Schumann Library & Learning Commons on the second floor.

Other locations and more about this service is available at https://wit.edu/tech-services/help-docs/printing/follow-me
Posted Jan 16, 2020 - 10:27 EST
This incident affected: Printing, Plotting, & Scanning.