Performance problem accessing Microsoft services from on-campus
Incident Report for Wentworth Institute of Technology
Resolved
This incident has been resolved.
Posted Sep 01, 2020 - 12:30 EDT
Monitoring
We believe this issue was related to our connection with Boston IX which normally carries traffic to Microsoft services and a BGP routing change that occurred. At this time the connection appears stable and we are continuing to monitor.
Posted Sep 01, 2020 - 11:02 EDT
Investigating
We are investigating reports of performance problem accessing Microsoft services from on-campus. This includes the Office 365 suite with Email and Teams. Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Sep 01, 2020 - 10:51 EDT
This incident affected: Internet and Network Access.