Blackboard Email not working
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Sep 30, 2020 - 08:36 EDT
Monitoring
Blackboard has applied a fix. At this email from Blackboard appears to be available. We are continuing to monitor the service.

If you are still experiencing the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Sep 28, 2020 - 18:22 EDT
Update
Blackboard has escalated case further and continues to investigate.
Users are advised to use Outlook or Navigate to communicate with classes.
Posted Sep 28, 2020 - 08:25 EDT
Update
We are continuing to work with Blackboard to correct this issue. In the meantime, instructors can use Outlook or Navigate to communicate with students.
Posted Sep 25, 2020 - 10:52 EDT
Update
Blackboard has escalated this case to tier 2 for further investigation.
Posted Sep 21, 2020 - 16:49 EDT
Investigating
Blackboard email still not functioning as expected.

Blackboard Technical support implemented a fix over the weekend which did not correct the problem. Our case has been escalated to tier 2 support to try to identify the cause of the problem.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Sep 21, 2020 - 09:46 EDT
Identified
Engineers have acknowledged a service interruption for Blackboard Email.

We are currently working to restore service and updates will be posted as they become available. Blackboard will be performing a rolling system restart (no downtime) this evening to correct the issue.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Sep 19, 2020 - 08:59 EDT
Investigating
We are working with Blackboard to identify the cause of a problem with the Blackboard email system that prevents users from sending email from within Blackboard.
Posted Sep 18, 2020 - 16:38 EDT
This incident affected: Digital Learning Environment (Blackboard Learn).