LConnect Unavailable
Incident Report for Wentworth Institute of Technology
Resolved
LConnect service is restored. Thank you for your patience.
Posted 5 months ago. Jul 24, 2018 - 10:56 EDT
Monitoring
At this time service may be available. Engineers are continuing to monitor the service and we will confirm once it has been fully tested.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 5 months ago. Jul 24, 2018 - 10:52 EDT
Identified
Engineers have acknowledged a service interruption for LConnect. Billing and registration services remain available through LeopardWeb at https://leopardweb.wit.edu

We are currently working to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 5 months ago. Jul 24, 2018 - 09:00 EDT
This incident affected: Student Information System.