Duo Phone Call and SMS Delivery issues to T-Mobile phone numbers
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Jun 16, 2020 - 07:44 EDT
Update
Additional information may be available from the Duo Status Page: https://status.duo.com/incidents/txv7kq6tr0h8
Posted Jun 15, 2020 - 17:34 EDT
Identified
Duo has acknowledged a service interruption for Phone Call and SMS Delivery issues to T-Mobile phone numbers. They are currently working to restore service and updates will be posted as they become available.

Work around: We recommend all users use the Duo App, rather than Phone or SMS authentication. If you have phone or SMS authentication configured and wish to switch to using the App, please contact us.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Jun 15, 2020 - 17:33 EDT
This incident affected: Authentication & Single Sign On (Authentication & Single Sign On).