Phone Issue on Campus
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 2 months ago. Mar 15, 2019 - 23:26 EDT
Investigating
DTS is investigating an issue with phone service being down on campus.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 2 months ago. Mar 15, 2019 - 23:02 EDT
This incident affected: Telephony & Collaboration.