Issues logging into Microsoft Office 365
Incident Report for Wentworth Institute of Technology
Resolved
This incident has been resolved.
Posted 4 months ago. Jan 29, 2019 - 22:17 EST
Monitoring
At this time service may be available. Microsoft is continuing to monitor the service and we will confirm once it has been fully tested.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 4 months ago. Jan 29, 2019 - 18:29 EST
Identified
Microsoft has identified an issue that is causing intermittent issues when logging in Office 365 for accessing applications such as the online version of Outlook.

Microsoft is currently working to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 4 months ago. Jan 29, 2019 - 16:53 EST
This incident affected: Cloud Productivity Tools.