Unable to Access Microsoft Teams
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

Thank you for your patience while Microsoft worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Feb 03, 2020 - 15:18 EST
Identified
Microsoft is currently experiencing an issue with MS Teams. Users may be unable to access Teams until they resolve the problem.

Microsoft is currently working to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Feb 03, 2020 - 10:32 EST
This incident affected: Cloud Productivity Tools.