Appointment Scheduling unavailable in CoVerified App
Incident Report for Wentworth Institute of Technology
Resolved
This incident has been resolved.
Posted Mar 24, 2021 - 07:52 EDT
Identified
Engineers have acknowledged a service interruption for COVID-19 test appointment scheduling in the CoVerified App. At this time, the testing hub is running normally and individuals should continue testing as usual without making an appointment.

We are currently working to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Mar 21, 2021 - 14:30 EDT
This incident affected: Other Services.