Edwards/Rodgers/Baker Hall Network Unavailable
Incident Report for Wentworth Institute of Technology
Resolved
Edwards/Rodgers/Baker electrical work has been completed and network service has been restored in these buildings.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or helpdesk@wit.edu. Thank you for your patience while we worked to restore normal service.
Posted 5 months ago. Dec 18, 2017 - 12:13 EST
Identified
Due to electrical work scheduled in Edwards and Rodgers Hall today, the wired and wireless network in those buildings and Baker Hall is currently unavailable.

Once power has been restored in the building we will test and confirm that network service is available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or helpdesk@wit.edu.
Posted 5 months ago. Dec 18, 2017 - 09:27 EST