Banner Outage
Incident Report for Wentworth Institute of Technology
Resolved
This incident has been resolved.
Posted 10 days ago. Jul 10, 2018 - 15:39 EDT
Investigating
Due to a database issue, we will be immediately restarting Banner Admin pages and LeopardWeb.
Posted 10 days ago. Jul 10, 2018 - 15:27 EDT
This incident affected: Student Information System.