Phone Issue on Campus
Incident Report for Wentworth Institute of Technology
Resolved
The phone issue on campus has been resolved. All phones are now functioning as expected.
Posted 10 months ago. Dec 29, 2017 - 19:05 EST
Investigating
DTS is currently investigating an issue with phones on campus not working. For any emergencies, please dial 911 until further notice.
Posted 10 months ago. Dec 29, 2017 - 18:26 EST