Delay in delivery of scanned material from Follow Me Printing devices
Incident Report for Wentworth Institute of Technology
Resolved
Timely delivery of scans from Follow Me Printing devices has resumed and backlog has been cleared
Posted 6 months ago. Dec 04, 2017 - 18:41 EST
Identified
Engineers have acknowledged a service delay for material scanned at Follow Me Printing devices on campus beginning Friday, December 1st.

We are currently working to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or helpdesk@wit.edu.
Posted 6 months ago. Dec 04, 2017 - 15:42 EST