Xfinity On Campus Sign In Error
Incident Report for Wentworth Institute of Technology
Resolved
Xfinity on Campus is working correctly for signing in.
Posted 10 months ago. Apr 18, 2017 - 21:12 EDT
Monitoring
Some users are now able to login to Xfinity on Campus. We are monitoring the situation and will update when fully functional.
Posted 10 months ago. Apr 18, 2017 - 16:33 EDT
Investigating
We are currently investigating an issue with Xfinity on Campus and errors when signing in. The issue appears to be with Xfinity and not with a Wentworth system. We are currently working with support to determine the cause and correct the issue.
Posted 10 months ago. Apr 18, 2017 - 14:09 EDT