555 Huntington Follow Me Printer Unavailable
Incident Report for Wentworth Institute of Technology
Resolved
555 Huntington Follow Me Printer is now available. Thank you for your patience while we worked to resolve this issue.
Posted about 1 month ago. Dec 11, 2018 - 11:06 EST
Identified
We are aware of a hardware issue with the Follow Me Printer located in 555 Huntington Avenue. Students should pick up their print jobs from alternate locations listed below until further notice.

* Douglas D. Schumann Library & Learning Commons
* Flanagan Campus Center
* Architecture Studios
* Interior Design Studio
* Industrial Design Studio
Posted about 1 month ago. Dec 10, 2018 - 11:37 EST
This incident affected: Printing, Plotting, & Scanning.