My Schedule and Courses tiles in myWentworth Unavailable
Incident Report for Wentworth Institute of Technology
Resolved
This incident has been resolved.
Posted Mar 18, 2021 - 22:00 EDT
Identified
Engineers have acknowledged a service interruption for My Schedule and Courses tiles in myWentworth.

We are currently working to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Mar 18, 2021 - 12:04 EDT
This incident affected: Web & Mobile (myWentworth App & Website).