Voice Mail Issue
Incident Report for Wentworth Institute of Technology
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 16, 2018 - 11:46 EDT
Update
We are continuing to investigate this issue.
Posted 5 months ago. Jul 16, 2018 - 11:45 EDT
Investigating
DTS is aware of an issue with voicemail not working. We are currently investigating the issue and will provide an update as soon as possible.
Posted 5 months ago. Jul 16, 2018 - 10:26 EDT
This incident affected: Telephony & Collaboration.