Phone Issue on Campus
Incident Report for Wentworth Institute of Technology
Resolved
Verizon has resolved their circuit issue and phones on campus are now functioning as expected.
Posted 11 months ago. Jan 18, 2018 - 09:39 EST
Identified
The phone issue on campus has been identified as a problem with a Verizon circuit that is affecting multiple customers. The vendor is working on resolving the issue as quickly as possible. We will provide an update once it is resolved.
Posted 11 months ago. Jan 18, 2018 - 07:45 EST
Investigating
DTS is currently investigating a problem with phones being down on campus. Public Safety can still be reached at their normal numbers.
Posted 11 months ago. Jan 18, 2018 - 06:24 EST