LeopardWeb and Banner Admin Unavailable
Incident Report for Wentworth Institute of Technology
Resolved
This incident has been resolved.
Posted Nov 17, 2021 - 07:08 EST
Investigating
We are currently investigating a database issue that is impacting LeopardWeb and Banner Admin.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Nov 17, 2021 - 06:49 EST
This incident affected: Student Information System.