Network Outage - Evans Way - 4th Floor
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 2 months ago. Mar 13, 2019 - 13:28 EDT
Investigating
DTS is investigating a network outage on the 4th floor of Evans Way.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 2 months ago. Mar 12, 2019 - 17:52 EDT
This incident affected: Internet and Network Access.