CoVerified Scheduling for Testing Hub Unavailable
Incident Report for Wentworth Institute of Technology
Resolved
Testing appointment scheduling in the CoVerified app is operational again. Download update v0.1.8 and restart the app.
Posted Aug 27, 2020 - 15:44 EDT
Update
We are continuing to investigate this issue.
Posted Aug 27, 2020 - 09:25 EDT
Investigating
The COVID-19 Case Management and Contact Tracing Team is aware of error messages attempting to schedule a testing appointment via CoVerified.

We are working with our support team regarding this issue and will post an update as soon as posssible.
Posted Aug 26, 2020 - 20:58 EDT
This incident affected: Other Services.