Isolated reports of network interruption on the academic campus.
Incident Report for Wentworth Institute of Technology
Resolved
This incident has been resolved
Posted 6 months ago. Jun 14, 2018 - 15:42 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 6 months ago. Jun 14, 2018 - 15:37 EDT
Investigating
We are investigating isolated reports of network interruptions on the academic campus.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 6 months ago. Jun 14, 2018 - 14:30 EDT
This incident affected: Internet and Network Access.