Blackboard Learn intermittent slow performance
Incident Report for Wentworth Institute of Technology
Postmortem

Blackboard RCA for 11/07/2019 performance degredation.

Posted Nov 15, 2019 - 09:26 EST

Resolved
This incident has been resolved.
Posted Nov 07, 2019 - 21:37 EST
Update
Blackboard has indicated receiving reports from other customers with similar issue and their network operations team is investigating further.

Updates will be posted as they become available.
Posted Nov 07, 2019 - 15:32 EST
Update
Blackboard requested additional information, which we have provided.

Updates will be posted as they become available.
Posted Nov 07, 2019 - 13:46 EST
Investigating
We are investigating multiple reports of intermittent slow performance when accessing Blackboard Learn.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Nov 07, 2019 - 10:40 EST